aboutsummaryrefslogtreecommitdiff
path: root/recipes-demo/de10-nano-gpio-apps/files/README_first.txt
diff options
context:
space:
mode:
authorWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-29 15:41:36 -0700
committerWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-30 16:35:30 -0700
commit9a293641b9abf9e4fca34f46a2de781f50847da9 (patch)
tree743a6aaa5f9834987a2e69881ced6eaf9efb3592 /recipes-demo/de10-nano-gpio-apps/files/README_first.txt
parent8abd3fefd939f796ae49191d6f5af641f2d624d0 (diff)
downloadmeta-de10-nano-9a293641b9abf9e4fca34f46a2de781f50847da9.tar.xz
Initial commit of de10-nano recipes
Please note that this is purely for development. Only superficial efforts have been made to resolve security concerns, and it should be noted that the board ships with an EMPTY ROOT PASSWORD and support for root login via ssh. This allows passwordless access to the board via ssh. recipes-bsp/u-boot: Contains the uboot 2017.03rc2 recipe and patches to support the de10-nano board recipes-connectivity/avahi: bbappend to remove unwanted packages recipes-connectivity/bluez: bbappend to add --compat to the bluetooth service to support legacy SDP APIs recipes-connectivity/openssh: bbappend to add a custom sshd_config recipes-core/base-files: bbappend to customize fstab and inputrc recipes-core/imagemagick: bbappend to change build configuration for the de10-nano board recipes-core/packagegroups: bbappend to remove an unwanted package recipes-core/webkit: bbappend to remove support for opengl recipes-demo: Various demo applications recipes-devtools: MRAA and UPM recipes recipes-images/angstrom/de10-nano-image.bb: DE10-Nano image definition recipes-kernel/de10-nano-linux-firmware: FPGA related firmware required for fpga configuration and devicetree overlay support recipes-kernel/linux: bbappend to customize configuration of linux kernel as well as patch in the de10-nano devicetree recipes-misc: various initialization and systemd scripts recipes-qt/qt5: bbappend to modify qt build options recipes-support/neon: bbappend to remove unwanted package recipes-support/upower: bbappend to remove unwanted package recipes-webserver: webserver configuration and webcontent for board hostedweb portal recipes-xfce/thunar-volman: bbappend to remove unwanted package recipes-xfce/xfce-pointers: add configuration so that xfce does not use the adxl input as a mouse recipes-xfce/xfce4-settings: bbappend to remove unwanted package Signed-off-by: Westergreen, Dalon <dalon.westergreen@intel.com>
Diffstat (limited to 'recipes-demo/de10-nano-gpio-apps/files/README_first.txt')
-rw-r--r--recipes-demo/de10-nano-gpio-apps/files/README_first.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-demo/de10-nano-gpio-apps/files/README_first.txt b/recipes-demo/de10-nano-gpio-apps/files/README_first.txt
new file mode 100644
index 0000000..fd26d84
--- /dev/null
+++ b/recipes-demo/de10-nano-gpio-apps/files/README_first.txt
@@ -0,0 +1,31 @@
+This directory contains three different example directories that contain
+documentation and examples for interacting with the GPIO resources on the Altas
+board.
+
+raw-gpio - contains a README file that describes how to discover and interact
+ with the gpio framework provided by the linux environment on the
+ DE10-Nano target. There is a script and two C programs that
+ demonstrate how to programmatically detect the state of the KEY0 push
+ button on the DE10-Nano board. The script and one C program simply
+ read the state, output it and exit, the second C program enables the
+ interrupt functionality for the GPIO and waits for the push button
+ press to generate the interrupt that it waits for.
+
+gpio-keys - contains a README file that describes how to discover and interact
+ with the gpio-keys framework provided by the linux environment on
+ the DE10-Nano target. There is a script and two C programs that
+ demonstrate how to programmatically detect the input events
+ generated by the SW0, SW1, SW2 and SW3 switches on the DE10-Nano
+ board. The script and one C program simply report the input events
+ as they are detected, the second C program adds a call to the
+ ioctl() function to read the current state of all four switches as
+ each input event is processed.
+
+gpio-leds - contains a README file that describes how to discover and interact
+ with the gpio-leds framework provided by the linux environment on
+ the DE10-Nano target. There is a script and a C program that
+ demonstrate how to programmatically control the LEDS on the
+ DE10-Nano board.
+
+Please see the README files in each sub directory for more information.
+