aboutsummaryrefslogtreecommitdiff
path: root/recipes-demo/de10-nano-fftsw-apps/files/images/README_IMAGES.TXT
diff options
context:
space:
mode:
authorWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-29 15:41:36 -0700
committerWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-30 16:35:30 -0700
commit9a293641b9abf9e4fca34f46a2de781f50847da9 (patch)
tree743a6aaa5f9834987a2e69881ced6eaf9efb3592 /recipes-demo/de10-nano-fftsw-apps/files/images/README_IMAGES.TXT
parent8abd3fefd939f796ae49191d6f5af641f2d624d0 (diff)
downloadmeta-de10-nano-9a293641b9abf9e4fca34f46a2de781f50847da9.tar.xz
Initial commit of de10-nano recipes
Please note that this is purely for development. Only superficial efforts have been made to resolve security concerns, and it should be noted that the board ships with an EMPTY ROOT PASSWORD and support for root login via ssh. This allows passwordless access to the board via ssh. recipes-bsp/u-boot: Contains the uboot 2017.03rc2 recipe and patches to support the de10-nano board recipes-connectivity/avahi: bbappend to remove unwanted packages recipes-connectivity/bluez: bbappend to add --compat to the bluetooth service to support legacy SDP APIs recipes-connectivity/openssh: bbappend to add a custom sshd_config recipes-core/base-files: bbappend to customize fstab and inputrc recipes-core/imagemagick: bbappend to change build configuration for the de10-nano board recipes-core/packagegroups: bbappend to remove an unwanted package recipes-core/webkit: bbappend to remove support for opengl recipes-demo: Various demo applications recipes-devtools: MRAA and UPM recipes recipes-images/angstrom/de10-nano-image.bb: DE10-Nano image definition recipes-kernel/de10-nano-linux-firmware: FPGA related firmware required for fpga configuration and devicetree overlay support recipes-kernel/linux: bbappend to customize configuration of linux kernel as well as patch in the de10-nano devicetree recipes-misc: various initialization and systemd scripts recipes-qt/qt5: bbappend to modify qt build options recipes-support/neon: bbappend to remove unwanted package recipes-support/upower: bbappend to remove unwanted package recipes-webserver: webserver configuration and webcontent for board hostedweb portal recipes-xfce/thunar-volman: bbappend to remove unwanted package recipes-xfce/xfce-pointers: add configuration so that xfce does not use the adxl input as a mouse recipes-xfce/xfce4-settings: bbappend to remove unwanted package Signed-off-by: Westergreen, Dalon <dalon.westergreen@intel.com>
Diffstat (limited to 'recipes-demo/de10-nano-fftsw-apps/files/images/README_IMAGES.TXT')
-rw-r--r--recipes-demo/de10-nano-fftsw-apps/files/images/README_IMAGES.TXT100
1 files changed, 100 insertions, 0 deletions
diff --git a/recipes-demo/de10-nano-fftsw-apps/files/images/README_IMAGES.TXT b/recipes-demo/de10-nano-fftsw-apps/files/images/README_IMAGES.TXT
new file mode 100644
index 0000000..a898907
--- /dev/null
+++ b/recipes-demo/de10-nano-fftsw-apps/files/images/README_IMAGES.TXT
@@ -0,0 +1,100 @@
+After you have built the FFT example programs in the src directory and run the
+'setup_target_fft_env.sh' script to install them into the ramdisk you can change
+into the 'output_waveforms' directory:
+
+root@DE10-Nano:/examples/fft/src# cd /mnt/ram/fft/output_waveforms/
+
+There should be no PNG image files in the directory at this point.
+
+output_waveforms# ls *.png
+ls: *.png: No such file or directory
+
+To create the PNG images for the output data from each FFT example program you
+can run each of the 'create_gnuplot_*.gnu' scripts like this:
+
+output_waveforms# find /examples/fft/src/images/ -name "create_gnuplot_*.gnu" \
+ -exec \{\} \;
+
+Now there should be an image file for each output data file:
+
+output_waveforms# ls *.png
+c16_256_sine.png fftdma_256_sine.png
+c16_256_square.png fftdma_256_square.png
+c16_256_triangle.png fftdma_256_triangle.png
+c16_256x32_sine.png fftdma_256x32_sine.png
+c16_256x32_square.png fftdma_256x32_square.png
+c16_256x32_triangle.png fftdma_256x32_triangle.png
+c16_4096_sine.png fftdma_4096_sine.png
+c16_4096_square.png fftdma_4096_square.png
+c16_4096_triangle.png fftdma_4096_triangle.png
+c32_256_sine.png neon16_256_sine.png
+c32_256_square.png neon16_256_square.png
+c32_256_triangle.png neon16_256_triangle.png
+c32_256x32_sine.png neon16_256x32_sine.png
+c32_256x32_square.png neon16_256x32_square.png
+c32_256x32_triangle.png neon16_256x32_triangle.png
+c32_4096_sine.png neon16_4096_sine.png
+c32_4096_square.png neon16_4096_square.png
+c32_4096_triangle.png neon16_4096_triangle.png
+fft_256_sine.png neon32_256_sine.png
+fft_256_square.png neon32_256_square.png
+fft_256_triangle.png neon32_256_triangle.png
+fft_256x32_sine.png neon32_256x32_sine.png
+fft_256x32_square.png neon32_256x32_square.png
+fft_256x32_triangle.png neon32_256x32_triangle.png
+fft_4096_sine.png neon32_4096_sine.png
+fft_4096_square.png neon32_4096_square.png
+fft_4096_triangle.png neon32_4096_triangle.png
+
+Now to package these image files up into a montage of each group of output we
+can run the 'create_montage_*.sh' scripts like this:
+
+output_waveforms# find /examples/fft/src/images/ -name "create_montage_*.sh" \
+ -exec \{\} \;
+
+Now we should see the montage images in the directory as well.
+
+output_waveforms# ls *.png
+c16_256_sine.png fftdma_256x32_triangle.png
+c16_256_square.png fftdma_4096_sine.png
+c16_256_triangle.png fftdma_4096_square.png
+c16_256x32_sine.png fftdma_4096_triangle.png
+c16_256x32_square.png neon16_256_sine.png
+c16_256x32_triangle.png neon16_256_square.png
+c16_4096_sine.png neon16_256_triangle.png
+c16_4096_square.png neon16_256x32_sine.png
+c16_4096_triangle.png neon16_256x32_square.png
+c32_256_sine.png neon16_256x32_triangle.png
+c32_256_square.png neon16_4096_sine.png
+c32_256_triangle.png neon16_4096_square.png
+c32_256x32_sine.png neon16_4096_triangle.png
+c32_256x32_square.png neon32_256_sine.png
+c32_256x32_triangle.png neon32_256_square.png
+c32_4096_sine.png neon32_256_triangle.png
+c32_4096_square.png neon32_256x32_sine.png
+c32_4096_triangle.png neon32_256x32_square.png
+fft_256_sine.png neon32_256x32_triangle.png
+fft_256_square.png neon32_4096_sine.png
+fft_256_triangle.png neon32_4096_square.png
+fft_256x32_sine.png neon32_4096_triangle.png
+fft_256x32_square.png sines_256.png
+fft_256x32_triangle.png sines_256x32.png
+fft_4096_sine.png sines_4096.png
+fft_4096_square.png squares_256.png
+fft_4096_triangle.png squares_256x32.png
+fftdma_256_sine.png squares_4096.png
+fftdma_256_square.png triangles_256.png
+fftdma_256_triangle.png triangles_256x32.png
+fftdma_256x32_sine.png triangles_4096.png
+fftdma_256x32_square.png
+
+Now to view these images you can do one of two things.
+
+If you are running a VNC session into the DE10-Nano target, then from the command
+prompt that you just ran the above commands from you can type 'display <image>'
+to run the Imagemagick file viewer. Otherwise, if you'd like to view these
+image files from a web browser on your host development, then copy the images
+into the '/usr/share/webcontent/images/' directory on the DE10-Nano target.
+Then from a web browser on your development host you can point your web browser
+to '<DE10-Nano-ip-address>/images/<image>'.
+