aboutsummaryrefslogtreecommitdiff
path: root/lib/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'lib/python/setup.py')
-rw-r--r--lib/python/setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/python/setup.py b/lib/python/setup.py
new file mode 100644
index 0000000..5e3c673
--- /dev/null
+++ b/lib/python/setup.py
@@ -0,0 +1,17 @@
+from setuptools import setup, Extension
+
+if __name__ == "__main__":
+ setup(
+ name="alarms",
+ version="0.1",
+ ext_modules=[
+ Extension(
+ "alarms",
+ language = "C",
+ sources = [ "alarms.c" ],
+ extra_compile_args = [ "-I../../inc" ],
+ libraries = [ "alarm", "uuid" ],
+ library_dirs = [ "../" ]
+ )
+ ]
+ )