aboutsummaryrefslogtreecommitdiff
path: root/lib/python/setup.py
diff options
context:
space:
mode:
authorDavid Phillips <david@sighup.nz>2019-05-08 22:01:55 +1200
committerDavid Phillips <david@sighup.nz>2019-05-08 22:43:07 +1200
commitccb9881319276e94fdede79c46c4f0d4c981dc41 (patch)
treef59898dd1881328b9fbf06160a194627462e56a7 /lib/python/setup.py
parentb01e76ae9cc32ee92e4203fe6d1c0e2f9edfe766 (diff)
downloadalarmd-ccb9881319276e94fdede79c46c4f0d4c981dc41.tar.xz
Refactor build process, use setup.pyHEADmaster
Diffstat (limited to 'lib/python/setup.py')
-rw-r--r--lib/python/setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/python/setup.py b/lib/python/setup.py
new file mode 100644
index 0000000..5e3c673
--- /dev/null
+++ b/lib/python/setup.py
@@ -0,0 +1,17 @@
+from setuptools import setup, Extension
+
+if __name__ == "__main__":
+ setup(
+ name="alarms",
+ version="0.1",
+ ext_modules=[
+ Extension(
+ "alarms",
+ language = "C",
+ sources = [ "alarms.c" ],
+ extra_compile_args = [ "-I../../inc" ],
+ libraries = [ "alarm", "uuid" ],
+ library_dirs = [ "../" ]
+ )
+ ]
+ )