aboutsummaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDavid Phillips <david@yeah.nah.nz>2019-07-27 21:36:51 +1200
committerDavid Phillips <david@yeah.nah.nz>2019-07-27 22:21:15 +1200
commitac84734859feb7db4994868dee6b74f73942380b (patch)
tree8df7c8430a1836c30cedfc0e62acf514e0554dfd /recipes-kernel
parent542eafc6f76cdc6d75975cd47eae5f455a8ee615 (diff)
downloadmeta-de10-nano-ac84734859feb7db4994868dee6b74f73942380b.tar.xz
Change kernel, U-Boot to stock, strip down image, add wic/wks
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-yocto_5%.bbappend38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_5%.bbappend b/recipes-kernel/linux/linux-yocto_5%.bbappend
new file mode 100644
index 0000000..a67ffc4
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_5%.bbappend
@@ -0,0 +1,38 @@
+PR = "r0"
+
+KBUILD_DEFCONFIG ?= "socfpga_defconfig"
+KBUILD_DEFCONFIG_stratix10swvp ?= "defconfig"
+KBUILD_DEFCONFIG_stratix10 ?= "defconfig"
+KBUILD_DEFCONFIG_10m50 ?= "10m50_defconfig"
+
+KCONFIG_MODE ?= "--alldefconfig"
+KBUILD_DEFCONFIG ?= "socfpga_defconfig"
+
+COMPATIBLE_MACHINE_de10-nano = "de10-nano"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/config:"
+
+SRC_URI_append_de0-nano += " \
+ file://socfpga-4.1-ltsi/cfg/configfs.cfg \
+ file://socfpga-4.1-ltsi/cfg/gpio-keys.cfg \
+ file://socfpga-4.1-ltsi/cfg/input_misc.cfg \
+ file://socfpga-4.1-ltsi/cfg/led-triggers.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_gadget.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_vid.cfg \
+ file://socfpga-4.1-ltsi/cfg/bluetooth.cfg \
+ file://socfpga-4.1-ltsi/cfg/wireless.cfg \
+ file://socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch \
+ "
+SRC_URI_append_de10-nano += " \
+ file://socfpga-4.1-ltsi/cfg/configfs.cfg \
+ file://socfpga-4.1-ltsi/cfg/gpio-keys.cfg \
+ file://socfpga-4.1-ltsi/cfg/input_misc.cfg \
+ file://socfpga-4.1-ltsi/cfg/led-triggers.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_gadget.cfg \
+ file://socfpga-4.1-ltsi/cfg/framebuffer.cfg \
+ file://socfpga-4.1-ltsi/cfg/framebuffer-console.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_vid.cfg \
+ file://socfpga-4.1-ltsi/cfg/bluetooth.cfg \
+ file://socfpga-4.1-ltsi/cfg/wireless.cfg \
+ file://socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch \
+ "