aboutsummaryrefslogtreecommitdiff
path: root/recipes-demo/de10-nano-fftsw-apps/files/README_SANDBOX_BUILD.TXT
diff options
context:
space:
mode:
authorWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-29 15:41:36 -0700
committerWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-30 16:35:30 -0700
commit9a293641b9abf9e4fca34f46a2de781f50847da9 (patch)
tree743a6aaa5f9834987a2e69881ced6eaf9efb3592 /recipes-demo/de10-nano-fftsw-apps/files/README_SANDBOX_BUILD.TXT
parent8abd3fefd939f796ae49191d6f5af641f2d624d0 (diff)
downloadmeta-de10-nano-9a293641b9abf9e4fca34f46a2de781f50847da9.tar.xz
Initial commit of de10-nano recipes
Please note that this is purely for development. Only superficial efforts have been made to resolve security concerns, and it should be noted that the board ships with an EMPTY ROOT PASSWORD and support for root login via ssh. This allows passwordless access to the board via ssh. recipes-bsp/u-boot: Contains the uboot 2017.03rc2 recipe and patches to support the de10-nano board recipes-connectivity/avahi: bbappend to remove unwanted packages recipes-connectivity/bluez: bbappend to add --compat to the bluetooth service to support legacy SDP APIs recipes-connectivity/openssh: bbappend to add a custom sshd_config recipes-core/base-files: bbappend to customize fstab and inputrc recipes-core/imagemagick: bbappend to change build configuration for the de10-nano board recipes-core/packagegroups: bbappend to remove an unwanted package recipes-core/webkit: bbappend to remove support for opengl recipes-demo: Various demo applications recipes-devtools: MRAA and UPM recipes recipes-images/angstrom/de10-nano-image.bb: DE10-Nano image definition recipes-kernel/de10-nano-linux-firmware: FPGA related firmware required for fpga configuration and devicetree overlay support recipes-kernel/linux: bbappend to customize configuration of linux kernel as well as patch in the de10-nano devicetree recipes-misc: various initialization and systemd scripts recipes-qt/qt5: bbappend to modify qt build options recipes-support/neon: bbappend to remove unwanted package recipes-support/upower: bbappend to remove unwanted package recipes-webserver: webserver configuration and webcontent for board hostedweb portal recipes-xfce/thunar-volman: bbappend to remove unwanted package recipes-xfce/xfce-pointers: add configuration so that xfce does not use the adxl input as a mouse recipes-xfce/xfce4-settings: bbappend to remove unwanted package Signed-off-by: Westergreen, Dalon <dalon.westergreen@intel.com>
Diffstat (limited to 'recipes-demo/de10-nano-fftsw-apps/files/README_SANDBOX_BUILD.TXT')
-rw-r--r--recipes-demo/de10-nano-fftsw-apps/files/README_SANDBOX_BUILD.TXT59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes-demo/de10-nano-fftsw-apps/files/README_SANDBOX_BUILD.TXT b/recipes-demo/de10-nano-fftsw-apps/files/README_SANDBOX_BUILD.TXT
new file mode 100644
index 0000000..be65e72
--- /dev/null
+++ b/recipes-demo/de10-nano-fftsw-apps/files/README_SANDBOX_BUILD.TXT
@@ -0,0 +1,59 @@
+To build the applications in this directory, you should be able to run these
+target scripts in this order:
+
+./sandbox_build_all.sh
+ this will build all the applications
+
+At this point everything should be built.
+
+Description of directory contents:
+
+sandbox_build_all.sh
+ target script to build all applications and libraries
+
+target_build_app.sh
+ target script to build one application
+
+target_build_lib.sh
+ target script to build one library
+
+clean_all.sh
+ target script to clean all build objects
+
+create_input_waveforms.sh
+ target script that executes waveform creation applications and
+ duplication scripts to create all input waveforms for the applications
+ to consume
+
+duplicate_x8.sh
+ this target script duplicates a file x8 times. This is used to
+ replicate the fundamental waveforms into longer patterns
+
+overhead.c
+ this is the source for the overhead library that all of the applications
+ are linked against
+
+fftdma_256.c
+ this application uses the FPGA logic to implement the FFT
+ algorithm for a variety of input sample sizes. This variant moves
+ the input samples into the FPGA and the results back out using DMA
+ through the ACP port of the Cortex A9 processor
+
+neon32_256.c
+ this application uses the NE10 NEON functions to implement the FFT
+ algorithm for a variety of input sample sizes with 32-bit resolution
+
+create_real_short_sine32.c
+create_real_short_square32.c
+create_real_short_triangle32.c
+ these applications create the initial 32 samples of their respective
+ waveform, sine, square and triangle
+
+real_short_to_ne10cpx_long.c
+ this application translates the real short data format into ne10cpx
+ long and short format which is consumed by the demo applications
+
+ne10cpx_long_to_text.c
+ this application translates the ne10cpx long and short format binary
+ data into text format output which may be read by gnu plot for example
+