aboutsummaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-29 15:41:36 -0700
committerWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-30 16:35:30 -0700
commit9a293641b9abf9e4fca34f46a2de781f50847da9 (patch)
tree743a6aaa5f9834987a2e69881ced6eaf9efb3592 /recipes-core
parent8abd3fefd939f796ae49191d6f5af641f2d624d0 (diff)
downloadmeta-de10-nano-9a293641b9abf9e4fca34f46a2de781f50847da9.tar.xz
Initial commit of de10-nano recipes
Please note that this is purely for development. Only superficial efforts have been made to resolve security concerns, and it should be noted that the board ships with an EMPTY ROOT PASSWORD and support for root login via ssh. This allows passwordless access to the board via ssh. recipes-bsp/u-boot: Contains the uboot 2017.03rc2 recipe and patches to support the de10-nano board recipes-connectivity/avahi: bbappend to remove unwanted packages recipes-connectivity/bluez: bbappend to add --compat to the bluetooth service to support legacy SDP APIs recipes-connectivity/openssh: bbappend to add a custom sshd_config recipes-core/base-files: bbappend to customize fstab and inputrc recipes-core/imagemagick: bbappend to change build configuration for the de10-nano board recipes-core/packagegroups: bbappend to remove an unwanted package recipes-core/webkit: bbappend to remove support for opengl recipes-demo: Various demo applications recipes-devtools: MRAA and UPM recipes recipes-images/angstrom/de10-nano-image.bb: DE10-Nano image definition recipes-kernel/de10-nano-linux-firmware: FPGA related firmware required for fpga configuration and devicetree overlay support recipes-kernel/linux: bbappend to customize configuration of linux kernel as well as patch in the de10-nano devicetree recipes-misc: various initialization and systemd scripts recipes-qt/qt5: bbappend to modify qt build options recipes-support/neon: bbappend to remove unwanted package recipes-support/upower: bbappend to remove unwanted package recipes-webserver: webserver configuration and webcontent for board hostedweb portal recipes-xfce/thunar-volman: bbappend to remove unwanted package recipes-xfce/xfce-pointers: add configuration so that xfce does not use the adxl input as a mouse recipes-xfce/xfce4-settings: bbappend to remove unwanted package Signed-off-by: Westergreen, Dalon <dalon.westergreen@intel.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files/base-files/fstab6
-rw-r--r--recipes-core/base-files/base-files/inputrc65
-rw-r--r--recipes-core/base-files/base-files_%.bbappend6
-rw-r--r--recipes-core/imagemagick/imagemagick_%.bbappend4
-rw-r--r--recipes-core/packagegroups/packagegroup-basic.bbappend1
-rw-r--r--recipes-core/webkit/webkitgtk_2.12.5.bbappend1
6 files changed, 83 insertions, 0 deletions
diff --git a/recipes-core/base-files/base-files/fstab b/recipes-core/base-files/base-files/fstab
new file mode 100644
index 0000000..8ff2ed6
--- /dev/null
+++ b/recipes-core/base-files/base-files/fstab
@@ -0,0 +1,6 @@
+/dev/root / auto defaults 1 1
+proc /proc proc defaults 0 0
+devpts /dev/pts devpts mode=0620,gid=5 0 0
+tmpfs /tmp tmpfs defaults 0 0
+
+/dev/mmcblk0p1 /media/FAT auto defaults 0 0
diff --git a/recipes-core/base-files/base-files/inputrc b/recipes-core/base-files/base-files/inputrc
new file mode 100644
index 0000000..0e37cbc
--- /dev/null
+++ b/recipes-core/base-files/base-files/inputrc
@@ -0,0 +1,65 @@
+# /etc/inputrc - global inputrc for libreadline
+# See readline(3readline) and `info rluserman' for more information.
+
+# Be 8 bit clean.
+set input-meta on
+set output-meta on
+
+# To allow the use of 8bit-characters like the german umlauts, comment out
+# the line below. However this makes the meta key not work as a meta key,
+# which is annoying to those which don't need to type in 8-bit characters.
+
+# set convert-meta off
+
+# try to enable the application keypad when it is called. Some systems
+# need this to enable the arrow keys.
+# set enable-keypad on
+
+# see /usr/share/doc/bash/inputrc.arrows for other codes of arrow keys
+
+# do not bell on tab-completion
+# set bell-style none
+
+# allow the use of the Home/End keys
+"\e[1~": beginning-of-line
+"\e[4~": end-of-line
+
+# some defaults / modifications for the emacs mode
+$if mode=emacs
+
+# allow the use of the Home/End keys
+# "\e[1~": beginning-of-line
+# "\e[4~": end-of-line
+
+# allow the use of the Delete/Insert keys
+# "\e[3~": delete-char
+# "\e[2~": quoted-insert
+
+# mappings for "page up" and "page down" to step to the beginning/end
+# of the history
+# "\e[5~": beginning-of-history
+# "\e[6~": end-of-history
+
+# alternate mappings for "page up" and "page down" to search the history
+# "\e[5~": history-search-backward
+# "\e[6~": history-search-forward
+
+# # mappings for Ctrl-left-arrow and Ctrl-right-arrow for word moving
+# "\e[5C": forward-word
+# "\e[5D": backward-word
+# "\e\e[C": forward-word
+# "\e\e[D": backward-word
+
+# $if term=rxvt
+# "\e[8~": end-of-line
+# $endif
+
+# for non RH/Debian xterm, can't hurt for RH/DEbian xterm
+# "\eOH": beginning-of-line
+# "\eOF": end-of-line
+
+# for freebsd console
+# "\e[H": beginning-of-line
+# "\e[F": end-of-line
+
+$endif
diff --git a/recipes-core/base-files/base-files_%.bbappend b/recipes-core/base-files/base-files_%.bbappend
new file mode 100644
index 0000000..2e5df72
--- /dev/null
+++ b/recipes-core/base-files/base-files_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+dirs755 += " /media/FAT"
+
+PRINC = "3"
+
diff --git a/recipes-core/imagemagick/imagemagick_%.bbappend b/recipes-core/imagemagick/imagemagick_%.bbappend
new file mode 100644
index 0000000..ab568c9
--- /dev/null
+++ b/recipes-core/imagemagick/imagemagick_%.bbappend
@@ -0,0 +1,4 @@
+# Override build config
+
+EXTRA_OECONF_de0-nano = "--program-prefix= --program-suffix= --with-x --without-perl --disable-openmp --without-xml --disable-opencl"
+EXTRA_OECONF_de10-nano = "--program-prefix= --program-suffix= --with-x --without-perl --disable-openmp --without-xml --disable-opencl"
diff --git a/recipes-core/packagegroups/packagegroup-basic.bbappend b/recipes-core/packagegroups/packagegroup-basic.bbappend
new file mode 100644
index 0000000..441ef04
--- /dev/null
+++ b/recipes-core/packagegroups/packagegroup-basic.bbappend
@@ -0,0 +1 @@
+RRECOMMENDS_${PN}_remove = "cpufrequtils"
diff --git a/recipes-core/webkit/webkitgtk_2.12.5.bbappend b/recipes-core/webkit/webkitgtk_2.12.5.bbappend
new file mode 100644
index 0000000..669be51
--- /dev/null
+++ b/recipes-core/webkit/webkitgtk_2.12.5.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"