aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <david@yeah.nah.nz>2020-01-25 21:25:53 +1300
committerDavid Phillips <david@yeah.nah.nz>2020-01-25 21:29:15 +1300
commit6fcdda011435640317adf8830e2a6ac07f9931cd (patch)
tree7bb2ec3c9816ef11408f7bf72b5acfaea4bc0c7e
parent596586b7522256bcd664d28d1a7072a6f8831b4d (diff)
downloadmeta-de10-nano-strip.tar.xz
Remove non-critical recipes failing during bootstrip
These recipes are mostly unneeded and are failing at boot in some way or another. For now, just remove them from the DE10 image.
-rw-r--r--conf/machine/include/de10-nano-common.inc2
-rw-r--r--recipes-core/base-files/base-files/fstab2
-rw-r--r--recipes-core/base-files/base-files_%.bbappend2
-rw-r--r--recipes-images/angstrom/de10-nano-image.bb16
-rw-r--r--recipes-kernel/linux/linux-yocto_5%.bbappend3
5 files changed, 6 insertions, 19 deletions
diff --git a/conf/machine/include/de10-nano-common.inc b/conf/machine/include/de10-nano-common.inc
index a64fa3f..41e9d45 100644
--- a/conf/machine/include/de10-nano-common.inc
+++ b/conf/machine/include/de10-nano-common.inc
@@ -1,5 +1,5 @@
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
-PREFERRED_VERSION_linux-yocto ?= "5.0%"
+PREFERRED_VERSION_linux-yocto ?= "5.2%"
#PREFERRED_VERSION_linux-altera-ltsi ?= "4.1%"
PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot"
diff --git a/recipes-core/base-files/base-files/fstab b/recipes-core/base-files/base-files/fstab
index 8ff2ed6..ea5e546 100644
--- a/recipes-core/base-files/base-files/fstab
+++ b/recipes-core/base-files/base-files/fstab
@@ -2,5 +2,3 @@
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
tmpfs /tmp tmpfs defaults 0 0
-
-/dev/mmcblk0p1 /media/FAT auto defaults 0 0
diff --git a/recipes-core/base-files/base-files_%.bbappend b/recipes-core/base-files/base-files_%.bbappend
index 2e5df72..023f45c 100644
--- a/recipes-core/base-files/base-files_%.bbappend
+++ b/recipes-core/base-files/base-files_%.bbappend
@@ -1,6 +1,4 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-dirs755 += " /media/FAT"
-
PRINC = "3"
diff --git a/recipes-images/angstrom/de10-nano-image.bb b/recipes-images/angstrom/de10-nano-image.bb
index 828bd28..4fba89e 100644
--- a/recipes-images/angstrom/de10-nano-image.bb
+++ b/recipes-images/angstrom/de10-nano-image.bb
@@ -6,8 +6,6 @@ LICENSE = "closed"
PV = '1.0'
PR = 'r0'
-DEPENDS += "bash perl gcc i2c-tools"
-
# FIXME put these in distro conf
VIRTUAL-RUNTIME_init_manager = "systemd"
VIRTUAL-RUNTIME_initscripts = "systemd-compat-units"
@@ -15,19 +13,15 @@ VIRTUAL-RUNTIME_initscripts = "systemd-compat-units"
IMAGE_INSTALL += " \
kernel-image \
kernel-modules \
- kernel-dev \
- linux-firmware \
systemd \
- lighttpd \
- lighttpd-module-cgi \
- bash gcc i2c-tools ethtool \
+ coreutils \
+ bash \
+ i2c-tools \
+ ethtool \
curl \
- e2fsprogs \
- de10-nano-gpio-apps \
- de10-nano-fpga-init \
de10-nano-fpga-leds \
- de10-nano-usb-gadget \
de10-nano-linux-firmware \
+ misc-tweaks \
"
export IMAGE_BASENAME = "de10-nano-image"
diff --git a/recipes-kernel/linux/linux-yocto_5%.bbappend b/recipes-kernel/linux/linux-yocto_5%.bbappend
index 33f4a97..e4cb8a5 100644
--- a/recipes-kernel/linux/linux-yocto_5%.bbappend
+++ b/recipes-kernel/linux/linux-yocto_5%.bbappend
@@ -22,7 +22,6 @@ SRC_URI_append_de0-nano += " \
file://socfpga-4.1-ltsi/cfg/bluetooth.cfg \
file://socfpga-4.1-ltsi/cfg/wireless.cfg \
file://socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch \
- file://socfpga-4.1-ltsi/patches/0001-ARM-dts-socfpga-update-more-missing-reset-properties.patch \
file://socfpga-4.1-ltsi/patches/0001-ARM-dts-socfpga-add-missing-reset-names-for-dma.patch \
file://socfpga-4.1-ltsi/patches/0001-ARM-8906-1-drivers-amba-add-reset-control-to-amba-bu.patch \
"
@@ -41,5 +40,3 @@ SRC_URI_append_de10-nano += " \
file://socfpga-4.1-ltsi/patches/0001-ARM-dts-socfpga-add-missing-reset-names-for-dma.patch \
file://socfpga-4.1-ltsi/patches/0001-ARM-8906-1-drivers-amba-add-reset-control-to-amba-bu.patch \
"
-
-# file://socfpga-4.1-ltsi/patches/0001-ARM-dts-socfpga-update-more-missing-reset-properties.patch