aboutsummaryrefslogtreecommitdiff
path: root/recipes-webserver
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-webserver')
-rw-r--r--recipes-webserver/de10-nano-lighttpd-conf/de10-nano-lighttpd-conf.bb24
-rw-r--r--recipes-webserver/de10-nano-webcontent/de10-nano-webcontent.bb39
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-webserver/de10-nano-lighttpd-conf/de10-nano-lighttpd-conf.bb b/recipes-webserver/de10-nano-lighttpd-conf/de10-nano-lighttpd-conf.bb
new file mode 100644
index 0000000..d40c437
--- /dev/null
+++ b/recipes-webserver/de10-nano-lighttpd-conf/de10-nano-lighttpd-conf.bb
@@ -0,0 +1,24 @@
+SUMMARY = "DE10-Nano customization"
+DESCRIPTION = "DE-Nano lighttpd configuration customization to enable cgi, set 404 page, and change serverroot"
+AUTHOR = "Dalon Westergreen <dwesterg@gmail.com>"
+SECTION = "DE10-Nano"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+inherit allarch
+ALLOW_EMPTY_${PN} = "1"
+
+PR = "r0"
+PV = "1.0${PR}"
+
+# Post process the lighttpd.conf file to enable cgi module, sets home page and update 404 page
+pkg_postinst_${PN}() {
+#!/bin/sh
+sed -ir 's:#\(.*mod_cgi\"\,\):\1:' $D/etc/lighttpd.conf
+sed -i '/server.document-root/c server.document-root = "/usr/share/webcontent"' $D/etc/lighttpd.conf
+sed -ir 's:\(index-file.names *\=\).*\(,\):\1 ("index.html"\2:' $D/etc/lighttpd.conf
+echo 'server.error-handler-404 = "/not_found.html"' >> $D/etc/lighttpd.conf
+echo 'cgi.assign = ( ".sh" => "/bin/sh" )' >> $D/etc/lighttpd.conf
+}
+
+RDEPENDS_{PN} = "lighttpd-module-cgi"
diff --git a/recipes-webserver/de10-nano-webcontent/de10-nano-webcontent.bb b/recipes-webserver/de10-nano-webcontent/de10-nano-webcontent.bb
new file mode 100644
index 0000000..cefc4f2
--- /dev/null
+++ b/recipes-webserver/de10-nano-webcontent/de10-nano-webcontent.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "DE10-Nano web content"
+AUTHOR = "Dalon Westergreen <dwesterg@gmail.com>"
+SECTION = "DE10-Nano"
+
+LICENSE = "MIT & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d252b8b27e3e6ea89c9c6912b3c4373d"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PR = "r0"
+
+SRCREV = "ed2d1c613328d48a35230e7ead3b9829476d6b82"
+PV = "1.0+git${SRCPV}"
+
+
+SRC_URI += " \
+ git://github.com/01org/de10-nano-webcontent.git;protocol=https \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+IMAGEDATESTAMP = "${@time.strftime('%Y.%m.%d',time.gmtime())}"
+
+do_install() {
+ install -d ${D}${datadir}/webcontent
+ cp -a ${S}/* ${D}${datadir}/webcontent
+ echo "DE10-Nano Image" > ${D}${datadir}/webcontent/assets/image-version-info.txt
+ echo "BUILD VERSION: ${IMAGEDATESTAMP}" >> ${D}${datadir}/webcontent/assets/image-version-info.txt
+ if [ -n "${DISTRO_NAME}" ]; then
+ echo -n "DISTRO: ${DISTRO_NAME} " >> ${D}${datadir}/webcontent/assets/image-version-info.txt
+ if [ -n "${DISTRO_VERSION}" ]; then
+ echo "${DISTRO_VERSION}" >> ${D}${datadir}/webcontent/assets/image-version-info.txt
+ fi
+ fi
+}
+
+FILES_${PN} += "${datadir}/webcontent"