aboutsummaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/de10-nano-linux-firmware/de10-nano-linux-firmware.bb48
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/block.cfg3
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/bluetooth.cfg51
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/configfs.cfg14
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer-console.cfg12
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer.cfg62
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/gpio-keys.cfg3
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/input_misc.cfg21
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/led-triggers.cfg11
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/uart.cfg12
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_gadget.cfg30
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_vid.cfg167
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/wireless.cfg136
-rw-r--r--recipes-kernel/linux/config/socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch143
-rw-r--r--recipes-kernel/linux/linux-altera-ltsi_4.1%.bbappend27
15 files changed, 740 insertions, 0 deletions
diff --git a/recipes-kernel/de10-nano-linux-firmware/de10-nano-linux-firmware.bb b/recipes-kernel/de10-nano-linux-firmware/de10-nano-linux-firmware.bb
new file mode 100644
index 0000000..bacd77a
--- /dev/null
+++ b/recipes-kernel/de10-nano-linux-firmware/de10-nano-linux-firmware.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Firmware for the DE0-Nano and DE10-Nano FPGAs"
+
+LICENSE = "Firmware-de10-nano & Firmware-de0-nano & MIT"
+
+LIC_FILES_CHKSUM = "\
+ file://${WORKDIR}/hardware/de10-nano/output_files/LICENSE.de10-nano.rbf;md5=b023c4e641168784dd29eca3d87d3dba \
+ file://${WORKDIR}/hardware/de0-nano/output_files/LICENSE.de0-nano.rbf;md5=4f612b7b520cc528f216ce2b7a6fd620 \
+ file://${WORKDIR}/hardware/LICENSE;md5=d252b8b27e3e6ea89c9c6912b3c4373d \
+"
+
+NO_GENERIC_LICENSE[Firmware-de10-nano] = "${WORKDIR}/hardware/de10-nano/output_files/LICENSE.de10-nano.rbf"
+NO_GENERIC_LICENSE[Firmware-de0-nano] = "${WORKDIR}/hardware/de0-nano/output_files/LICENSE.de0-nano.rbf"
+
+inherit deploy
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRCREV_FORMAT = "hardware"
+
+# Build:03-22-17_01.32.46 QUARTUS:Version=16.1.2.203
+SRCREV_hardware = "d03450606b22a5f4f0d39da79fe169745ceffbec"
+
+PV="${PN}+git${SRCPV}"
+
+SRC_URI += " \
+ git://github.com/01org/de10-nano-hardware.git;destsuffix=hardware;name=hardware;branch=RELEASE_BUILDS;protocol=https \
+"
+
+do_install () {
+ cd ${WORKDIR}/hardware
+ install -d ${D}${base_libdir}/firmware
+ install -m 0644 LICENSE ${D}${base_libdir}/firmware/LICENSE.${MACHINE}.dtbo
+ install -m 0644 devicetrees/${MACHINE}.dtbo ${D}${base_libdir}/firmware
+
+}
+
+do_deploy () {
+ cd ${WORKDIR}/hardware
+ install -d ${DEPLOYDIR}
+ install -m 0644 ${MACHINE}/output_files/LICENSE.${MACHINE}.rbf ${DEPLOYDIR}
+ install -m 0644 ${MACHINE}/output_files/${MACHINE}.rbf ${DEPLOYDIR}
+}
+
+addtask deploy after do_install
+
+FILES_${PN} = "${base_libdir}/firmware"
+LICENSE_${PN} = "MIT"
+
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/block.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/block.cfg
new file mode 100644
index 0000000..f60a5ef
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/block.cfg
@@ -0,0 +1,3 @@
+CONFIG_LBDAF=y
+# CONFIG_XFS_FS is not set
+# CONFIG_GFS2_FS is not set
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/bluetooth.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/bluetooth.cfg
new file mode 100644
index 0000000..d333c8a
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/bluetooth.cfg
@@ -0,0 +1,51 @@
+CONFIG_BT=y
+CONFIG_BT_BREDR=y
+CONFIG_BT_RFCOMM=y
+CONFIG_BT_RFCOMM_TTY=y
+CONFIG_BT_BNEP=y
+CONFIG_BT_BNEP_MC_FILTER=y
+CONFIG_BT_BNEP_PROTO_FILTER=y
+CONFIG_BT_HIDP=y
+CONFIG_BT_LE=y
+CONFIG_BT_SELFTEST=y
+CONFIG_BT_SELFTEST_ECDH=y
+CONFIG_BT_SELFTEST_SMP=y
+CONFIG_BT_DEBUGFS=y
+
+#
+# Bluetooth device drivers
+#
+CONFIG_BT_INTEL=y
+CONFIG_BT_BCM=y
+CONFIG_BT_HCIBTUSB=y
+CONFIG_BT_HCIBTUSB_BCM=y
+CONFIG_BT_HCIBTSDIO=y
+CONFIG_BT_HCIUART=y
+CONFIG_BT_HCIUART_H4=y
+CONFIG_BT_HCIUART_BCSP=y
+CONFIG_BT_HCIUART_ATH3K=y
+CONFIG_BT_HCIUART_LL=y
+CONFIG_BT_HCIUART_3WIRE=y
+CONFIG_BT_HCIUART_INTEL=y
+CONFIG_BT_HCIUART_BCM=y
+CONFIG_BT_HCIBCM203X=y
+CONFIG_BT_HCIBPA10X=y
+CONFIG_BT_HCIBFUSB=y
+CONFIG_BT_HCIVHCI=y
+CONFIG_BT_MRVL=y
+CONFIG_BT_MRVL_SDIO=y
+CONFIG_BT_ATH3K=y
+CONFIG_WANT_DEV_COREDUMP=y
+CONFIG_DEV_COREDUMP=y
+CONFIG_CRYPTO_AEAD2=y
+CONFIG_CRYPTO_BLKCIPHER=y
+CONFIG_CRYPTO_BLKCIPHER2=y
+CONFIG_CRYPTO_RNG2=y
+CONFIG_CRYPTO_PCOMP2=y
+CONFIG_CRYPTO_MANAGER=y
+CONFIG_CRYPTO_MANAGER2=y
+CONFIG_CRYPTO_MANAGER_DISABLE_TESTS=y
+CONFIG_CRYPTO_WORKQUEUE=y
+CONFIG_CRYPTO_ECB=y
+CONFIG_CRYPTO_CMAC=y
+CONFIG_CRYPTO_SHA256=y
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/configfs.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/configfs.cfg
new file mode 100644
index 0000000..0b98ff7
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/configfs.cfg
@@ -0,0 +1,14 @@
+CONFIG_USB_F_EEM=m
+CONFIG_USB_CONFIGFS=m
+CONFIG_USB_CONFIGFS_SERIAL=y
+CONFIG_USB_CONFIGFS_ACM=y
+CONFIG_USB_CONFIGFS_OBEX=y
+CONFIG_USB_CONFIGFS_NCM=y
+CONFIG_USB_CONFIGFS_ECM=y
+CONFIG_USB_CONFIGFS_ECM_SUBSET=y
+CONFIG_USB_CONFIGFS_RNDIS=y
+CONFIG_USB_CONFIGFS_EEM=y
+CONFIG_USB_CONFIGFS_MASS_STORAGE=y
+CONFIG_USB_CONFIGFS_F_LB_SS=y
+CONFIG_USB_CONFIGFS_F_FS=y
+CONFIG_USB_CONFIGFS_F_HID=y
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer-console.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer-console.cfg
new file mode 100644
index 0000000..133c9bd
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer-console.cfg
@@ -0,0 +1,12 @@
+CONFIG_VT_HW_CONSOLE_BINDING=y
+CONFIG_FRAMEBUFFER_CONSOLE=y
+# CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY is not set
+# CONFIG_FRAMEBUFFER_CONSOLE_ROTATION is not set
+CONFIG_LOGO=y
+CONFIG_LOGO_LINUX_MONO=y
+CONFIG_LOGO_LINUX_VGA16=y
+CONFIG_LOGO_LINUX_CLUT224=y
+CONFIG_FONT_SUPPORT=y
+# CONFIG_FONTS is not set
+CONFIG_FONT_8x8=y
+CONFIG_FONT_8x16=y
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer.cfg
new file mode 100644
index 0000000..ef7a33b
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/framebuffer.cfg
@@ -0,0 +1,62 @@
+CONFIG_FB=y
+# CONFIG_FIRMWARE_EDID is not set
+CONFIG_FB_CMDLINE=y
+# CONFIG_FB_DDC is not set
+# CONFIG_FB_BOOT_VESA_SUPPORT is not set
+CONFIG_FB_CFB_FILLRECT=y
+CONFIG_FB_CFB_COPYAREA=y
+CONFIG_FB_CFB_IMAGEBLIT=y
+# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
+# CONFIG_FB_SYS_FILLRECT is not set
+# CONFIG_FB_SYS_COPYAREA is not set
+# CONFIG_FB_SYS_IMAGEBLIT is not set
+# CONFIG_FB_FOREIGN_ENDIAN is not set
+# CONFIG_FB_SYS_FOPS is not set
+# CONFIG_FB_SVGALIB is not set
+# CONFIG_FB_MACMODES is not set
+# CONFIG_FB_BACKLIGHT is not set
+# CONFIG_FB_MODE_HELPERS is not set
+# CONFIG_FB_TILEBLITTING is not set
+
+#
+# Frame buffer hardware drivers
+#
+# CONFIG_FB_ALTERA_VIP is not set
+# CONFIG_FB_CIRRUS is not set
+# CONFIG_FB_PM2 is not set
+# CONFIG_FB_ARMCLCD is not set
+# CONFIG_FB_CYBER2000 is not set
+# CONFIG_FB_ASILIANT is not set
+# CONFIG_FB_IMSTT is not set
+# CONFIG_FB_OPENCORES is not set
+# CONFIG_FB_S1D13XXX is not set
+# CONFIG_FB_NVIDIA is not set
+# CONFIG_FB_RIVA is not set
+# CONFIG_FB_I740 is not set
+# CONFIG_FB_MATROX is not set
+# CONFIG_FB_RADEON is not set
+# CONFIG_FB_ATY128 is not set
+# CONFIG_FB_ATY is not set
+# CONFIG_FB_S3 is not set
+# CONFIG_FB_SAVAGE is not set
+# CONFIG_FB_SIS is not set
+# CONFIG_FB_NEOMAGIC is not set
+# CONFIG_FB_KYRO is not set
+# CONFIG_FB_3DFX is not set
+# CONFIG_FB_VOODOO1 is not set
+# CONFIG_FB_VT8623 is not set
+# CONFIG_FB_TRIDENT is not set
+# CONFIG_FB_ARK is not set
+# CONFIG_FB_PM3 is not set
+# CONFIG_FB_CARMINE is not set
+# CONFIG_FB_SMSCUFX is not set
+# CONFIG_FB_UDL is not set
+# CONFIG_FB_VIRTUAL is not set
+# CONFIG_FB_METRONOME is not set
+# CONFIG_FB_MB862XX is not set
+# CONFIG_FB_BROADSHEET is not set
+# CONFIG_FB_AUO_K190X is not set
+CONFIG_FB_SIMPLE=y
+# CONFIG_FB_SSD1307 is not set
+# CONFIG_FRAMEBUFFER_CONSOLE is not set
+# CONFIG_LOGO is not set
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/gpio-keys.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/gpio-keys.cfg
new file mode 100644
index 0000000..5b81a9c
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/gpio-keys.cfg
@@ -0,0 +1,3 @@
+CONFIG_KEYBOARD_GPIO_POLLED=y
+CONFIG_INPUT_POLLDEV=y
+CONFIG_KEYBOARD_GPIO=y
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/input_misc.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/input_misc.cfg
new file mode 100644
index 0000000..6f2ef6d
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/input_misc.cfg
@@ -0,0 +1,21 @@
+CONFIG_INPUT_MISC=y
+# CONFIG_INPUT_AD714X is not set
+# CONFIG_INPUT_BMA150 is not set
+# CONFIG_INPUT_MMA8450 is not set
+# CONFIG_INPUT_MPU3050 is not set
+# CONFIG_INPUT_GP2A is not set
+# CONFIG_INPUT_GPIO_TILT_POLLED is not set
+# CONFIG_INPUT_ATI_REMOTE2 is not set
+# CONFIG_INPUT_KEYSPAN_REMOTE is not set
+# CONFIG_INPUT_KXTJ9 is not set
+# CONFIG_INPUT_POWERMATE is not set
+# CONFIG_INPUT_YEALINK is not set
+# CONFIG_INPUT_CM109 is not set
+# CONFIG_INPUT_UINPUT is not set
+# CONFIG_INPUT_PCF8574 is not set
+# CONFIG_INPUT_GPIO_ROTARY_ENCODER is not set
+CONFIG_INPUT_ADXL34X=y
+CONFIG_INPUT_ADXL34X_I2C=y
+CONFIG_INPUT_ADXL34X_SPI=y
+# CONFIG_INPUT_IMS_PCU is not set
+# CONFIG_INPUT_CMA3000 is not set
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/led-triggers.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/led-triggers.cfg
new file mode 100644
index 0000000..76d0eae
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/led-triggers.cfg
@@ -0,0 +1,11 @@
+CONFIG_NEW_LEDS=y
+CONFIG_LEDS_CLASS=y
+CONFIG_LEDS_GPIO=y
+CONFIG_LEDS_TRIGGERS=y
+CONFIG_LEDS_TRIGGER_TIMER=y
+CONFIG_LEDS_TRIGGER_ONESHOT=y
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_LEDS_TRIGGER_BACKLIGHT=y
+CONFIG_LEDS_TRIGGER_CPU=y
+CONFIG_LEDS_TRIGGER_GPIO=y
+CONFIG_LEDS_TRIGGER_DEFAULT_ON=y
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/uart.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/uart.cfg
new file mode 100644
index 0000000..6c70182
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/uart.cfg
@@ -0,0 +1,12 @@
+CONFIG_SERIAL_8250_NR_UARTS=4
+CONFIG_SERIAL_8250_RUNTIME_UARTS=4
+CONFIG_SERIAL_8250_EXTENDED=y
+CONFIG_SERIAL_8250_MANY_PORTS=y
+# CONFIG_SERIAL_8250_SHARE_IRQ is not set
+# CONFIG_SERIAL_8250_DETECT_IRQ is not set
+# CONFIG_SERIAL_8250_RSA is not set
+CONFIG_SERIAL_ALTERA_UART=y
+CONFIG_SERIAL_ALTERA_UART_MAXPORTS=4
+CONFIG_SERIAL_ALTERA_UART_BAUDRATE=115200
+# CONFIG_SERIAL_ALTERA_UART_CONSOLE is not set
+CONFIG_SERIAL_OF_PLATFORM=y
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_gadget.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_gadget.cfg
new file mode 100644
index 0000000..df9c4a8
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_gadget.cfg
@@ -0,0 +1,30 @@
+CONFIG_USB_GADGET=y
+CONFIG_USB_GADGET_DEBUG=y
+CONFIG_USB_GADGET_DEBUG_FILES=y
+CONFIG_USB_GADGET_DEBUG_FS=y
+CONFIG_USB_GADGET_VBUS_DRAW=2
+CONFIG_USB_GADGET_STORAGE_NUM_BUFFERS=2
+CONFIG_USB_LIBCOMPOSITE=m
+CONFIG_USB_F_ACM=m
+CONFIG_USB_F_SS_LB=m
+CONFIG_USB_U_SERIAL=m
+CONFIG_USB_F_SERIAL=m
+CONFIG_USB_F_OBEX=m
+CONFIG_USB_ZERO=m
+CONFIG_USB_ETH=m
+CONFIG_USB_ETH_RNDIS=y
+# CONFIG_USB_ETH_EEM is not set
+CONFIG_USB_G_NCM=m
+CONFIG_USB_GADGETFS=m
+CONFIG_USB_FUNCTIONFS=m
+CONFIG_USB_FUNCTIONFS_ETH=y
+CONFIG_USB_FUNCTIONFS_RNDIS=y
+CONFIG_USB_FUNCTIONFS_GENERIC=y
+CONFIG_USB_MASS_STORAGE=m
+CONFIG_USB_G_SERIAL=m
+CONFIG_USB_G_PRINTER=m
+CONFIG_USB_CDC_COMPOSITE=m
+CONFIG_USB_G_ACM_MS=m
+CONFIG_USB_G_MULTI=m
+CONFIG_USB_G_MULTI_RNDIS=y
+CONFIG_USB_G_HID=m
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_vid.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_vid.cfg
new file mode 100644
index 0000000..70ebdef
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/usb_vid.cfg
@@ -0,0 +1,167 @@
+CONFIG_DMA_SHARED_BUFFER=y
+# CONFIG_FENCE_TRACE is not set
+CONFIG_I2C_MUX=y
+
+#
+# Multiplexer I2C Chip support
+#
+# CONFIG_I2C_ARB_GPIO_CHALLENGE is not set
+# CONFIG_I2C_MUX_GPIO is not set
+# CONFIG_I2C_MUX_PCA9541 is not set
+# CONFIG_I2C_MUX_PCA954x is not set
+CONFIG_MEDIA_SUPPORT=y
+
+#
+# Multimedia core support
+#
+CONFIG_MEDIA_CAMERA_SUPPORT=y
+# CONFIG_MEDIA_ANALOG_TV_SUPPORT is not set
+# CONFIG_MEDIA_DIGITAL_TV_SUPPORT is not set
+# CONFIG_MEDIA_RADIO_SUPPORT is not set
+# CONFIG_MEDIA_SDR_SUPPORT is not set
+# CONFIG_MEDIA_RC_SUPPORT is not set
+# CONFIG_MEDIA_CONTROLLER is not set
+CONFIG_VIDEO_DEV=y
+CONFIG_VIDEO_V4L2=y
+# CONFIG_VIDEO_ADV_DEBUG is not set
+# CONFIG_VIDEO_FIXED_MINOR_RANGES is not set
+CONFIG_VIDEOBUF2_CORE=y
+CONFIG_VIDEOBUF2_MEMOPS=y
+CONFIG_VIDEOBUF2_VMALLOC=y
+# CONFIG_TTPCI_EEPROM is not set
+
+#
+# Media drivers
+#
+CONFIG_MEDIA_USB_SUPPORT=y
+
+#
+# Webcam devices
+#
+CONFIG_USB_VIDEO_CLASS=y
+CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
+CONFIG_USB_GSPCA=y
+# CONFIG_USB_M5602 is not set
+# CONFIG_USB_STV06XX is not set
+# CONFIG_USB_GL860 is not set
+# CONFIG_USB_GSPCA_BENQ is not set
+# CONFIG_USB_GSPCA_CONEX is not set
+# CONFIG_USB_GSPCA_CPIA1 is not set
+# CONFIG_USB_GSPCA_DTCS033 is not set
+# CONFIG_USB_GSPCA_ETOMS is not set
+# CONFIG_USB_GSPCA_FINEPIX is not set
+# CONFIG_USB_GSPCA_JEILINJ is not set
+# CONFIG_USB_GSPCA_JL2005BCD is not set
+# CONFIG_USB_GSPCA_KINECT is not set
+# CONFIG_USB_GSPCA_KONICA is not set
+# CONFIG_USB_GSPCA_MARS is not set
+# CONFIG_USB_GSPCA_MR97310A is not set
+# CONFIG_USB_GSPCA_NW80X is not set
+# CONFIG_USB_GSPCA_OV519 is not set
+# CONFIG_USB_GSPCA_OV534 is not set
+# CONFIG_USB_GSPCA_OV534_9 is not set
+# CONFIG_USB_GSPCA_PAC207 is not set
+# CONFIG_USB_GSPCA_PAC7302 is not set
+# CONFIG_USB_GSPCA_PAC7311 is not set
+# CONFIG_USB_GSPCA_SE401 is not set
+# CONFIG_USB_GSPCA_SN9C2028 is not set
+# CONFIG_USB_GSPCA_SN9C20X is not set
+# CONFIG_USB_GSPCA_SONIXB is not set
+# CONFIG_USB_GSPCA_SONIXJ is not set
+# CONFIG_USB_GSPCA_SPCA500 is not set
+# CONFIG_USB_GSPCA_SPCA501 is not set
+# CONFIG_USB_GSPCA_SPCA505 is not set
+# CONFIG_USB_GSPCA_SPCA506 is not set
+# CONFIG_USB_GSPCA_SPCA508 is not set
+# CONFIG_USB_GSPCA_SPCA561 is not set
+# CONFIG_USB_GSPCA_SPCA1528 is not set
+# CONFIG_USB_GSPCA_SQ905 is not set
+# CONFIG_USB_GSPCA_SQ905C is not set
+# CONFIG_USB_GSPCA_SQ930X is not set
+# CONFIG_USB_GSPCA_STK014 is not set
+# CONFIG_USB_GSPCA_STK1135 is not set
+# CONFIG_USB_GSPCA_STV0680 is not set
+# CONFIG_USB_GSPCA_SUNPLUS is not set
+# CONFIG_USB_GSPCA_T613 is not set
+# CONFIG_USB_GSPCA_TOPRO is not set
+# CONFIG_USB_GSPCA_TOUPTEK is not set
+# CONFIG_USB_GSPCA_TV8532 is not set
+# CONFIG_USB_GSPCA_VC032X is not set
+# CONFIG_USB_GSPCA_VICAM is not set
+# CONFIG_USB_GSPCA_XIRLINK_CIT is not set
+# CONFIG_USB_GSPCA_ZC3XX is not set
+# CONFIG_USB_PWC is not set
+# CONFIG_VIDEO_CPIA2 is not set
+# CONFIG_USB_ZR364XX is not set
+# CONFIG_USB_STKWEBCAM is not set
+# CONFIG_USB_S2255 is not set
+
+#
+# Webcam, TV (analog/digital) USB devices
+#
+# CONFIG_VIDEO_EM28XX is not set
+# CONFIG_MEDIA_PCI_SUPPORT is not set
+# CONFIG_V4L_PLATFORM_DRIVERS is not set
+# CONFIG_V4L_MEM2MEM_DRIVERS is not set
+# CONFIG_V4L_TEST_DRIVERS is not set
+
+#
+# Supported MMC/SDIO adapters
+#
+# CONFIG_CYPRESS_FIRMWARE is not set
+
+#
+# Media ancillary drivers (tuners, sensors, i2c, frontends)
+#
+CONFIG_MEDIA_SUBDRV_AUTOSELECT=y
+
+#
+# Audio decoders, processors and mixers
+#
+
+#
+# RDS decoders
+#
+
+#
+# Video decoders
+#
+
+#
+# Video and audio decoders
+#
+
+#
+# Video encoders
+#
+
+#
+# Camera sensor devices
+#
+
+#
+# Flash devices
+#
+
+#
+# Video improvement chips
+#
+
+#
+# Audio/Video compression chips
+#
+
+#
+# Miscellaneous helper chips
+#
+
+#
+# Sensors used on soc_camera driver
+#
+
+#
+# Tools to develop new frontends
+#
+# CONFIG_DVB_DUMMY_FE is not set
+# CONFIG_USB_CONFIGFS_F_UVC is not set
+# CONFIG_USB_G_WEBCAM is not set
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/wireless.cfg b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/wireless.cfg
new file mode 100644
index 0000000..cb5bcda
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/cfg/wireless.cfg
@@ -0,0 +1,136 @@
+CONFIG_WEXT_CORE=y
+CONFIG_WEXT_PROC=y
+CONFIG_CFG80211=y
+CONFIG_NL80211_TESTMODE=y
+# CONFIG_CFG80211_DEVELOPER_WARNINGS is not set
+# CONFIG_CFG80211_REG_DEBUG is not set
+# CONFIG_CFG80211_CERTIFICATION_ONUS is not set
+CONFIG_CFG80211_DEFAULT_PS=y
+CONFIG_CFG80211_DEBUGFS=y
+# CONFIG_CFG80211_INTERNAL_REGDB is not set
+CONFIG_CFG80211_WEXT=y
+CONFIG_MAC80211=y
+CONFIG_MAC80211_HAS_RC=y
+CONFIG_MAC80211_RC_MINSTREL=y
+CONFIG_MAC80211_RC_MINSTREL_HT=y
+# CONFIG_MAC80211_RC_MINSTREL_VHT is not set
+CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
+CONFIG_MAC80211_RC_DEFAULT="minstrel_ht"
+# CONFIG_MAC80211_MESH is not set
+CONFIG_MAC80211_LEDS=y
+CONFIG_MAC80211_DEBUGFS=y
+# CONFIG_MAC80211_MESSAGE_TRACING is not set
+# CONFIG_MAC80211_DEBUG_MENU is not set
+CONFIG_EEPROM_93CX6=y
+CONFIG_USB_USBNET=y
+CONFIG_USB_NET_AX8817X=y
+CONFIG_USB_NET_AX88179_178A=y
+CONFIG_USB_NET_CDCETHER=y
+# CONFIG_USB_NET_CDC_EEM is not set
+CONFIG_USB_NET_CDC_NCM=y
+# CONFIG_USB_NET_HUAWEI_CDC_NCM is not set
+# CONFIG_USB_NET_CDC_MBIM is not set
+# CONFIG_USB_NET_DM9601 is not set
+# CONFIG_USB_NET_SR9700 is not set
+# CONFIG_USB_NET_SR9800 is not set
+# CONFIG_USB_NET_SMSC75XX is not set
+# CONFIG_USB_NET_SMSC95XX is not set
+# CONFIG_USB_NET_GL620A is not set
+CONFIG_USB_NET_NET1080=y
+# CONFIG_USB_NET_PLUSB is not set
+# CONFIG_USB_NET_MCS7830 is not set
+CONFIG_USB_NET_RNDIS_HOST=y
+CONFIG_USB_NET_CDC_SUBSET=y
+# CONFIG_USB_ALI_M5632 is not set
+# CONFIG_USB_AN2720 is not set
+CONFIG_USB_BELKIN=y
+CONFIG_USB_ARMLINUX=y
+# CONFIG_USB_EPSON2888 is not set
+# CONFIG_USB_KC2190 is not set
+CONFIG_USB_NET_ZAURUS=y
+# CONFIG_USB_NET_CX82310_ETH is not set
+# CONFIG_USB_NET_KALMIA is not set
+# CONFIG_USB_NET_QMI_WWAN is not set
+# CONFIG_USB_NET_INT51X1 is not set
+# CONFIG_USB_SIERRA_NET is not set
+# CONFIG_USB_VL600 is not set
+# CONFIG_LIBERTAS_THINFIRM is not set
+# CONFIG_ATMEL is not set
+# CONFIG_AT76C50X_USB is not set
+# CONFIG_USB_ZD1201 is not set
+CONFIG_USB_NET_RNDIS_WLAN=y
+# CONFIG_RTL8180 is not set
+CONFIG_RTL8187=y
+CONFIG_RTL8187_LEDS=y
+# CONFIG_ADM8211 is not set
+# CONFIG_MAC80211_HWSIM is not set
+# CONFIG_MWL8K is not set
+# CONFIG_ATH_CARDS is not set
+# CONFIG_B43 is not set
+# CONFIG_B43LEGACY is not set
+# CONFIG_BRCMSMAC is not set
+# CONFIG_BRCMFMAC is not set
+# CONFIG_IPW2100 is not set
+# CONFIG_IPW2200 is not set
+# CONFIG_IWLWIFI is not set
+# CONFIG_IWL4965 is not set
+# CONFIG_IWL3945 is not set
+# CONFIG_LIBERTAS is not set
+# CONFIG_HERMES is not set
+# CONFIG_P54_COMMON is not set
+CONFIG_RT2X00=y
+# CONFIG_RT2400PCI is not set
+# CONFIG_RT2500PCI is not set
+# CONFIG_RT61PCI is not set
+# CONFIG_RT2800PCI is not set
+CONFIG_RT2500USB=y
+CONFIG_RT73USB=y
+CONFIG_RT2800USB=y
+CONFIG_RT2800USB_RT33XX=y
+CONFIG_RT2800USB_RT35XX=y
+CONFIG_RT2800USB_RT3573=y
+CONFIG_RT2800USB_RT53XX=y
+CONFIG_RT2800USB_RT55XX=y
+CONFIG_RT2800USB_UNKNOWN=y
+CONFIG_RT2800_LIB=y
+CONFIG_RT2X00_LIB_USB=y
+CONFIG_RT2X00_LIB=y
+CONFIG_RT2X00_LIB_FIRMWARE=y
+CONFIG_RT2X00_LIB_CRYPTO=y
+CONFIG_RT2X00_LIB_LEDS=y
+CONFIG_RT2X00_LIB_DEBUGFS=y
+CONFIG_RT2X00_DEBUG=y
+CONFIG_RTL_CARDS=y
+CONFIG_RTL8192CE=y
+CONFIG_RTL8192SE=y
+CONFIG_RTL8192DE=y
+# CONFIG_RTL8723AE is not set
+# CONFIG_RTL8723BE is not set
+CONFIG_RTL8188EE=y
+CONFIG_RTL8192EE=y
+CONFIG_RTL8821AE=y
+CONFIG_RTL8192CU=y
+CONFIG_RTLWIFI=y
+CONFIG_RTLWIFI_PCI=y
+CONFIG_RTLWIFI_USB=y
+CONFIG_RTLWIFI_DEBUG=y
+CONFIG_RTL8192C_COMMON=y
+CONFIG_RTLBTCOEXIST=y
+CONFIG_ZD1211RW=y
+# CONFIG_ZD1211RW_DEBUG is not set
+# CONFIG_MWIFIEX is not set
+# CONFIG_CW1200 is not set
+# CONFIG_RSI_91X is not set
+CONFIG_CRYPTO_AEAD=y
+CONFIG_CRYPTO_RNG=y
+CONFIG_CRYPTO_GF128MUL=y
+CONFIG_CRYPTO_NULL=y
+CONFIG_CRYPTO_CCM=y
+CONFIG_CRYPTO_GCM=y
+CONFIG_CRYPTO_SEQIV=y
+CONFIG_CRYPTO_CTR=y
+CONFIG_CRYPTO_GHASH=y
+CONFIG_CRYPTO_ARC4=y
+CONFIG_CRC_CCITT=y
+CONFIG_CRC_ITU_T=y
+CONFIG_AVERAGE=y
diff --git a/recipes-kernel/linux/config/socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch b/recipes-kernel/linux/config/socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch
new file mode 100644
index 0000000..d41fe34
--- /dev/null
+++ b/recipes-kernel/linux/config/socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch
@@ -0,0 +1,143 @@
+From ccc00a9eb345e3f45836d764211da4dd723aef52 Mon Sep 17 00:00:00 2001
+From: Dalon Westergreen <dalon.westergreen@intel.com>
+Date: Sun, 5 Feb 2017 12:30:18 -0800
+Subject: [PATCH] Add DE10-Nano devicetree
+
+Devicetree for Terasic's DE10-Nano SoC board
+
+Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com>
+---
+ arch/arm/boot/dts/socfpga_cyclone5_de10_nano.dts | 121 +++++++++++++++++++++++
+ 1 file changed, 121 insertions(+)
+ create mode 100644 arch/arm/boot/dts/socfpga_cyclone5_de10_nano.dts
+
+diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de10_nano.dts b/arch/arm/boot/dts/socfpga_cyclone5_de10_nano.dts
+new file mode 100644
+index 0000000..fe14a85
+--- /dev/null
++++ b/arch/arm/boot/dts/socfpga_cyclone5_de10_nano.dts
+@@ -0,0 +1,121 @@
++/*
++ * Copyright Intel Corporation (C) 2017. All rights reserved.
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms and conditions of the GNU General Public License,
++ * version 2, as published by the Free Software Foundation.
++ *
++ * This program is distributed in the hope it will be useful, but WITHOUT
++ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
++ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
++ * more details.
++ *
++ * You should have received a copy of the GNU General Public License along with
++ * this program. If not, see <http://www.gnu.org/licenses/>.
++ */
++
++#include "socfpga_cyclone5.dtsi"
++
++/ {
++ model = "Terasic DE10-Nano";
++ compatible = "altr,socfpga-cyclone5", "altr,socfpga";
++
++ chosen {
++ bootargs = "earlyprintk";
++ stdout-path = "serial0:115200n8";
++ };
++
++ memory {
++ name = "memory";
++ device_type = "memory";
++ reg = <0x0 0x40000000>; /* 1GB */
++ };
++
++ aliases {
++ ethernet0 = &gmac1;
++ };
++
++ regulator_3_3v: 3-3-v-regulator {
++ compatible = "regulator-fixed";
++ regulator-name = "3.3V";
++ regulator-min-microvolt = <3300000>;
++ regulator-max-microvolt = <3300000>;
++ };
++
++ leds {
++ compatible = "gpio-leds";
++ hps0 {
++ label = "hps_led0";
++ gpios = <&portb 24 0>;
++ linux,default-trigger = "heartbeat";
++ };
++ };
++
++ keys {
++ compatible = "gpio-keys";
++ hps0 {
++ label = "hps_key0";
++ gpios = <&portb 25 0>;
++ linux,code = <63>;
++ debounce-interval = <50>;
++ };
++ };
++};
++
++&gmac1 {
++ status = "okay";
++ phy-mode = "rgmii";
++
++ txd0-skew-ps = <0>; /* -420ps */
++ txd1-skew-ps = <0>; /* -420ps */
++ txd2-skew-ps = <0>; /* -420ps */
++ txd3-skew-ps = <0>; /* -420ps */
++ rxd0-skew-ps = <420>; /* 0ps */
++ rxd1-skew-ps = <420>; /* 0ps */
++ rxd2-skew-ps = <420>; /* 0ps */
++ rxd3-skew-ps = <420>; /* 0ps */
++ txen-skew-ps = <0>; /* -420ps */
++ txc-skew-ps = <1860>; /* 960ps */
++ rxdv-skew-ps = <420>; /* 0ps */
++ rxc-skew-ps = <1680>; /* 780ps */
++
++ max-frame-size = <3800>;
++};
++
++&gpio0 {
++ status = "okay";
++};
++
++&gpio1 {
++ status = "okay";
++};
++
++&gpio2 {
++ status = "okay";
++};
++
++&i2c0 {
++ status = "okay";
++ speed-mode = <0>;
++
++ adxl345: adxl345@0 {
++ compatible = "adi,adxl34x";
++ reg = <0x53>;
++
++ interrupt-parent = <&portc>;
++ interrupts = <3 2>;
++ };
++};
++
++&mmc0 {
++ vmmc-supply = <&regulator_3_3v>;
++ vqmmc-supply = <&regulator_3_3v>;
++};
++
++&uart0 {
++ status = "okay";
++};
++
++&usb1 {
++ status = "okay";
++};
+--
+2.7.4
+
diff --git a/recipes-kernel/linux/linux-altera-ltsi_4.1%.bbappend b/recipes-kernel/linux/linux-altera-ltsi_4.1%.bbappend
new file mode 100644
index 0000000..67e81fd
--- /dev/null
+++ b/recipes-kernel/linux/linux-altera-ltsi_4.1%.bbappend
@@ -0,0 +1,27 @@
+PR = "r0"
+FILESEXTRAPATHS_prepend := "${THISDIR}/config:"
+
+SRC_URI_append_de0-nano += " \
+ file://socfpga-4.1-ltsi/cfg/configfs.cfg \
+ file://socfpga-4.1-ltsi/cfg/gpio-keys.cfg \
+ file://socfpga-4.1-ltsi/cfg/input_misc.cfg \
+ file://socfpga-4.1-ltsi/cfg/led-triggers.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_gadget.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_vid.cfg \
+ file://socfpga-4.1-ltsi/cfg/bluetooth.cfg \
+ file://socfpga-4.1-ltsi/cfg/wireless.cfg \
+ file://socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch \
+ "
+SRC_URI_append_de10-nano += " \
+ file://socfpga-4.1-ltsi/cfg/configfs.cfg \
+ file://socfpga-4.1-ltsi/cfg/gpio-keys.cfg \
+ file://socfpga-4.1-ltsi/cfg/input_misc.cfg \
+ file://socfpga-4.1-ltsi/cfg/led-triggers.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_gadget.cfg \
+ file://socfpga-4.1-ltsi/cfg/framebuffer.cfg \
+ file://socfpga-4.1-ltsi/cfg/framebuffer-console.cfg \
+ file://socfpga-4.1-ltsi/cfg/usb_vid.cfg \
+ file://socfpga-4.1-ltsi/cfg/bluetooth.cfg \
+ file://socfpga-4.1-ltsi/cfg/wireless.cfg \
+ file://socfpga-4.1-ltsi/patches/0001-Add-DE10-Nano-devicetree.patch \
+ "