aboutsummaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files/base-files/fstab6
-rw-r--r--recipes-core/base-files/base-files/inputrc65
-rw-r--r--recipes-core/base-files/base-files_%.bbappend6
-rw-r--r--recipes-core/imagemagick/imagemagick_%.bbappend4
-rw-r--r--recipes-core/packagegroups/packagegroup-basic.bbappend1
-rw-r--r--recipes-core/webkit/webkitgtk_2.12.5.bbappend1
6 files changed, 83 insertions, 0 deletions
diff --git a/recipes-core/base-files/base-files/fstab b/recipes-core/base-files/base-files/fstab
new file mode 100644
index 0000000..8ff2ed6
--- /dev/null
+++ b/recipes-core/base-files/base-files/fstab
@@ -0,0 +1,6 @@
+/dev/root / auto defaults 1 1
+proc /proc proc defaults 0 0
+devpts /dev/pts devpts mode=0620,gid=5 0 0
+tmpfs /tmp tmpfs defaults 0 0
+
+/dev/mmcblk0p1 /media/FAT auto defaults 0 0
diff --git a/recipes-core/base-files/base-files/inputrc b/recipes-core/base-files/base-files/inputrc
new file mode 100644
index 0000000..0e37cbc
--- /dev/null
+++ b/recipes-core/base-files/base-files/inputrc
@@ -0,0 +1,65 @@
+# /etc/inputrc - global inputrc for libreadline
+# See readline(3readline) and `info rluserman' for more information.
+
+# Be 8 bit clean.
+set input-meta on
+set output-meta on
+
+# To allow the use of 8bit-characters like the german umlauts, comment out
+# the line below. However this makes the meta key not work as a meta key,
+# which is annoying to those which don't need to type in 8-bit characters.
+
+# set convert-meta off
+
+# try to enable the application keypad when it is called. Some systems
+# need this to enable the arrow keys.
+# set enable-keypad on
+
+# see /usr/share/doc/bash/inputrc.arrows for other codes of arrow keys
+
+# do not bell on tab-completion
+# set bell-style none
+
+# allow the use of the Home/End keys
+"\e[1~": beginning-of-line
+"\e[4~": end-of-line
+
+# some defaults / modifications for the emacs mode
+$if mode=emacs
+
+# allow the use of the Home/End keys
+# "\e[1~": beginning-of-line
+# "\e[4~": end-of-line
+
+# allow the use of the Delete/Insert keys
+# "\e[3~": delete-char
+# "\e[2~": quoted-insert
+
+# mappings for "page up" and "page down" to step to the beginning/end
+# of the history
+# "\e[5~": beginning-of-history
+# "\e[6~": end-of-history
+
+# alternate mappings for "page up" and "page down" to search the history
+# "\e[5~": history-search-backward
+# "\e[6~": history-search-forward
+
+# # mappings for Ctrl-left-arrow and Ctrl-right-arrow for word moving
+# "\e[5C": forward-word
+# "\e[5D": backward-word
+# "\e\e[C": forward-word
+# "\e\e[D": backward-word
+
+# $if term=rxvt
+# "\e[8~": end-of-line
+# $endif
+
+# for non RH/Debian xterm, can't hurt for RH/DEbian xterm
+# "\eOH": beginning-of-line
+# "\eOF": end-of-line
+
+# for freebsd console
+# "\e[H": beginning-of-line
+# "\e[F": end-of-line
+
+$endif
diff --git a/recipes-core/base-files/base-files_%.bbappend b/recipes-core/base-files/base-files_%.bbappend
new file mode 100644
index 0000000..2e5df72
--- /dev/null
+++ b/recipes-core/base-files/base-files_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+dirs755 += " /media/FAT"
+
+PRINC = "3"
+
diff --git a/recipes-core/imagemagick/imagemagick_%.bbappend b/recipes-core/imagemagick/imagemagick_%.bbappend
new file mode 100644
index 0000000..ab568c9
--- /dev/null
+++ b/recipes-core/imagemagick/imagemagick_%.bbappend
@@ -0,0 +1,4 @@
+# Override build config
+
+EXTRA_OECONF_de0-nano = "--program-prefix= --program-suffix= --with-x --without-perl --disable-openmp --without-xml --disable-opencl"
+EXTRA_OECONF_de10-nano = "--program-prefix= --program-suffix= --with-x --without-perl --disable-openmp --without-xml --disable-opencl"
diff --git a/recipes-core/packagegroups/packagegroup-basic.bbappend b/recipes-core/packagegroups/packagegroup-basic.bbappend
new file mode 100644
index 0000000..441ef04
--- /dev/null
+++ b/recipes-core/packagegroups/packagegroup-basic.bbappend
@@ -0,0 +1 @@
+RRECOMMENDS_${PN}_remove = "cpufrequtils"
diff --git a/recipes-core/webkit/webkitgtk_2.12.5.bbappend b/recipes-core/webkit/webkitgtk_2.12.5.bbappend
new file mode 100644
index 0000000..669be51
--- /dev/null
+++ b/recipes-core/webkit/webkitgtk_2.12.5.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"