aboutsummaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/files/v2017.03/0001-arm-socfpga-Move-CONFIG_EXTRA_ENV_SETTINGS-to-common.patch
diff options
context:
space:
mode:
authorWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-29 15:41:36 -0700
committerWestergreen, Dalon <dalon.westergreen@intel.com>2017-03-30 16:35:30 -0700
commit9a293641b9abf9e4fca34f46a2de781f50847da9 (patch)
tree743a6aaa5f9834987a2e69881ced6eaf9efb3592 /recipes-bsp/u-boot/files/v2017.03/0001-arm-socfpga-Move-CONFIG_EXTRA_ENV_SETTINGS-to-common.patch
parent8abd3fefd939f796ae49191d6f5af641f2d624d0 (diff)
downloadmeta-de10-nano-9a293641b9abf9e4fca34f46a2de781f50847da9.tar.xz
Initial commit of de10-nano recipes
Please note that this is purely for development. Only superficial efforts have been made to resolve security concerns, and it should be noted that the board ships with an EMPTY ROOT PASSWORD and support for root login via ssh. This allows passwordless access to the board via ssh. recipes-bsp/u-boot: Contains the uboot 2017.03rc2 recipe and patches to support the de10-nano board recipes-connectivity/avahi: bbappend to remove unwanted packages recipes-connectivity/bluez: bbappend to add --compat to the bluetooth service to support legacy SDP APIs recipes-connectivity/openssh: bbappend to add a custom sshd_config recipes-core/base-files: bbappend to customize fstab and inputrc recipes-core/imagemagick: bbappend to change build configuration for the de10-nano board recipes-core/packagegroups: bbappend to remove an unwanted package recipes-core/webkit: bbappend to remove support for opengl recipes-demo: Various demo applications recipes-devtools: MRAA and UPM recipes recipes-images/angstrom/de10-nano-image.bb: DE10-Nano image definition recipes-kernel/de10-nano-linux-firmware: FPGA related firmware required for fpga configuration and devicetree overlay support recipes-kernel/linux: bbappend to customize configuration of linux kernel as well as patch in the de10-nano devicetree recipes-misc: various initialization and systemd scripts recipes-qt/qt5: bbappend to modify qt build options recipes-support/neon: bbappend to remove unwanted package recipes-support/upower: bbappend to remove unwanted package recipes-webserver: webserver configuration and webcontent for board hostedweb portal recipes-xfce/thunar-volman: bbappend to remove unwanted package recipes-xfce/xfce-pointers: add configuration so that xfce does not use the adxl input as a mouse recipes-xfce/xfce4-settings: bbappend to remove unwanted package Signed-off-by: Westergreen, Dalon <dalon.westergreen@intel.com>
Diffstat (limited to 'recipes-bsp/u-boot/files/v2017.03/0001-arm-socfpga-Move-CONFIG_EXTRA_ENV_SETTINGS-to-common.patch')
-rw-r--r--recipes-bsp/u-boot/files/v2017.03/0001-arm-socfpga-Move-CONFIG_EXTRA_ENV_SETTINGS-to-common.patch102
1 files changed, 102 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/files/v2017.03/0001-arm-socfpga-Move-CONFIG_EXTRA_ENV_SETTINGS-to-common.patch b/recipes-bsp/u-boot/files/v2017.03/0001-arm-socfpga-Move-CONFIG_EXTRA_ENV_SETTINGS-to-common.patch
new file mode 100644
index 0000000..fd6b83f
--- /dev/null
+++ b/recipes-bsp/u-boot/files/v2017.03/0001-arm-socfpga-Move-CONFIG_EXTRA_ENV_SETTINGS-to-common.patch
@@ -0,0 +1,102 @@
+From 59d8f9e085deb935565ebcdaaf97ff2dddaae3b8 Mon Sep 17 00:00:00 2001
+From: Dalon Westergreen <dwesterg@gmail.com>
+Date: Mon, 6 Feb 2017 10:07:14 -0800
+Subject: [PATCH 1/6] arm: socfpga: Move CONFIG_EXTRA_ENV_SETTINGS to common
+
+Move CONFIG_EXTRA_ENV_SETTINGS to common header and add support
+for distro boot.
+
+Add support for distro_boot in the socfpga common header.
+
+Signed-off-by: Dalon Westergreen <dwesterg@gmail.com>
+---
+ include/configs/socfpga_common.h | 49 ++++++++++++++++++++++++++++++++++++----
+ 1 file changed, 45 insertions(+), 4 deletions(-)
+
+diff --git a/include/configs/socfpga_common.h b/include/configs/socfpga_common.h
+index 8472b52..e0b08ec 100644
+--- a/include/configs/socfpga_common.h
++++ b/include/configs/socfpga_common.h
+@@ -65,6 +65,9 @@
+ #define CONFIG_SYS_HOSTNAME CONFIG_SYS_BOARD
+ #endif
+
++#define CONFIG_CMD_PXE
++#define CONFIG_MENU
++
+ /*
+ * Cache
+ */
+@@ -242,13 +245,13 @@ unsigned int cm_get_qspi_controller_clk_hz(void);
+ * U-Boot environment
+ */
+ #if !defined(CONFIG_ENV_SIZE)
+-#define CONFIG_ENV_SIZE 4096
++#define CONFIG_ENV_SIZE (8*1024)
+ #endif
+
+ /* Environment for SDMMC boot */
+ #if defined(CONFIG_ENV_IS_IN_MMC) && !defined(CONFIG_ENV_OFFSET)
+-#define CONFIG_SYS_MMC_ENV_DEV 0 /* device 0 */
+-#define CONFIG_ENV_OFFSET 512 /* just after the MBR */
++#define CONFIG_SYS_MMC_ENV_DEV 0 /* device 0 */
++#define CONFIG_ENV_OFFSET (34*512)/* just after the GPT */
+ #endif
+
+ /* Environment for QSPI boot */
+@@ -305,8 +308,12 @@ unsigned int cm_get_qspi_controller_clk_hz(void);
+ /* SPL SDMMC boot support */
+ #ifdef CONFIG_SPL_MMC_SUPPORT
+ #if defined(CONFIG_SPL_FAT_SUPPORT) || defined(CONFIG_SPL_EXT_SUPPORT)
+-#define CONFIG_SYS_MMCSD_FS_BOOT_PARTITION 2
+ #define CONFIG_SPL_FS_LOAD_PAYLOAD_NAME "u-boot-dtb.img"
++#define CONFIG_SYS_MMCSD_FS_BOOT_PARTITION 1
++#endif
++#else
++#ifndef CONFIG_SYS_MMCSD_RAW_MODE_U_BOOT_PARTITION
++#define CONFIG_SYS_MMCSD_RAW_MODE_U_BOOT_PARTITION 1
+ #endif
+ #endif
+
+@@ -328,4 +335,38 @@ unsigned int cm_get_qspi_controller_clk_hz(void);
+ */
+ #define CONFIG_SPL_STACK CONFIG_SYS_INIT_SP_ADDR
+
++/* Extra Environment */
++#ifndef CONFIG_SPL_BUILD
++#include <config_distro_defaults.h>
++
++#ifdef CONFIG_CMD_PXE
++#define BOOT_TARGET_DEVICES_PXE(func) func(PXE, pxe, na)
++#else
++#define BOOT_TARGET_DEVICES_PXE(func)
++#endif
++
++#define BOOT_TARGET_DEVICES(func) \
++ func(MMC, mmc, 0) \
++ BOOT_TARGET_DEVICES_PXE(func) \
++ func(DHCP, dhcp, na)
++
++#include <config_distro_bootcmd.h>
++
++#ifndef CONFIG_EXTRA_ENV_SETTINGS
++#define CONFIG_EXTRA_ENV_SETTINGS \
++ "verify=n\0" \
++ "bootimage=" CONFIG_BOOTFILE "\0" \
++ "fdt_addr=100\0" \
++ "fdtfile=" CONFIG_DEFAULT_FDT_FILE "\0" \
++ "bootm_size=0xa000000\0" \
++ "kernel_addr_r="__stringify(CONFIG_SYS_LOAD_ADDR)"\0" \
++ "fdt_addr_r=0x02000000\0" \
++ "scriptaddr=0x02100000\0" \
++ "pxefile_addr_r=0x02200000\0" \
++ "ramdisk_addr_r=0x02300000\0" \
++ BOOTENV
++
++#endif
++#endif
++
+ #endif /* __CONFIG_SOCFPGA_COMMON_H__ */
+--
+2.7.4
+