From 9a293641b9abf9e4fca34f46a2de781f50847da9 Mon Sep 17 00:00:00 2001
From: "Westergreen, Dalon" <dalon.westergreen@intel.com>
Date: Wed, 29 Mar 2017 15:41:36 -0700
Subject: Initial commit of de10-nano recipes

Please note that this is purely for development.  Only superficial
efforts have been made to resolve security concerns, and it should
be noted that the board ships with an EMPTY ROOT PASSWORD and support
for root login via ssh.  This allows passwordless access to the board
via ssh.

recipes-bsp/u-boot:
Contains the uboot 2017.03rc2 recipe and patches to support the
de10-nano board

recipes-connectivity/avahi:
bbappend to remove unwanted packages

recipes-connectivity/bluez:
bbappend to add --compat to the bluetooth service to support legacy
SDP APIs

recipes-connectivity/openssh:
bbappend to add a custom sshd_config

recipes-core/base-files:
bbappend to customize fstab and inputrc

recipes-core/imagemagick:
bbappend to change build configuration for the de10-nano board

recipes-core/packagegroups:
bbappend to remove an unwanted package

recipes-core/webkit:
bbappend to remove support for opengl

recipes-demo:
Various demo applications

recipes-devtools:
MRAA and UPM recipes

recipes-images/angstrom/de10-nano-image.bb:
DE10-Nano image definition

recipes-kernel/de10-nano-linux-firmware:
FPGA related firmware required for fpga configuration and devicetree
overlay support

recipes-kernel/linux:
bbappend to customize configuration of linux kernel as well as patch
in the de10-nano devicetree

recipes-misc:
various initialization and systemd scripts

recipes-qt/qt5:
bbappend to modify qt build options

recipes-support/neon:
bbappend to remove unwanted package

recipes-support/upower:
bbappend to remove unwanted package

recipes-webserver:
webserver configuration and webcontent for board hostedweb portal

recipes-xfce/thunar-volman:
bbappend to remove unwanted package

recipes-xfce/xfce-pointers:
add configuration so that xfce does not use the adxl input as a mouse

recipes-xfce/xfce4-settings:
bbappend to remove unwanted package

Signed-off-by: Westergreen, Dalon <dalon.westergreen@intel.com>
---
 .../de10-nano-usb-gadget/files/de10-nano-gadget-init.service   | 10 ++++++++++
 .../de10-nano-usb-gadget/files/de10-nano-gadget-init.sh        | 10 ++++++++++
 recipes-misc/de10-nano-usb-gadget/files/udhcpd.conf            |  5 +++++
 3 files changed, 25 insertions(+)
 create mode 100644 recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.service
 create mode 100644 recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.sh
 create mode 100644 recipes-misc/de10-nano-usb-gadget/files/udhcpd.conf

(limited to 'recipes-misc/de10-nano-usb-gadget/files')

diff --git a/recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.service b/recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.service
new file mode 100644
index 0000000..4e7f7de
--- /dev/null
+++ b/recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Start usb mass storage gadget
+After=dev-mmcblk0p1.device
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/de10-nano-gadget-init.sh
+
+[Install]
+WantedBy=basic.target
diff --git a/recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.sh b/recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.sh
new file mode 100644
index 0000000..4bfa204
--- /dev/null
+++ b/recipes-misc/de10-nano-usb-gadget/files/de10-nano-gadget-init.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+modprobe g_multi file=/usr/share/de10-nano-usb-gadget/fat_image.img
+
+sleep 5
+
+rm /var/lib/misc/udhcpd.leases
+/sbin/ifconfig usb0 hw ether 00:07:ed:01:02:03
+/sbin/ifconfig usb0 192.168.7.1 netmask 255.255.255.0
+/usr/sbin/udhcpd -fS -I 192.168.7.1 /etc/udhcpd.conf
diff --git a/recipes-misc/de10-nano-usb-gadget/files/udhcpd.conf b/recipes-misc/de10-nano-usb-gadget/files/udhcpd.conf
new file mode 100644
index 0000000..78102f6
--- /dev/null
+++ b/recipes-misc/de10-nano-usb-gadget/files/udhcpd.conf
@@ -0,0 +1,5 @@
+start      192.168.7.5
+end        192.168.7.6
+interface  usb0
+max_leases 1
+option subnet 255.255.255.0
-- 
cgit v1.1