From 9a293641b9abf9e4fca34f46a2de781f50847da9 Mon Sep 17 00:00:00 2001
From: "Westergreen, Dalon" <dalon.westergreen@intel.com>
Date: Wed, 29 Mar 2017 15:41:36 -0700
Subject: Initial commit of de10-nano recipes

Please note that this is purely for development.  Only superficial
efforts have been made to resolve security concerns, and it should
be noted that the board ships with an EMPTY ROOT PASSWORD and support
for root login via ssh.  This allows passwordless access to the board
via ssh.

recipes-bsp/u-boot:
Contains the uboot 2017.03rc2 recipe and patches to support the
de10-nano board

recipes-connectivity/avahi:
bbappend to remove unwanted packages

recipes-connectivity/bluez:
bbappend to add --compat to the bluetooth service to support legacy
SDP APIs

recipes-connectivity/openssh:
bbappend to add a custom sshd_config

recipes-core/base-files:
bbappend to customize fstab and inputrc

recipes-core/imagemagick:
bbappend to change build configuration for the de10-nano board

recipes-core/packagegroups:
bbappend to remove an unwanted package

recipes-core/webkit:
bbappend to remove support for opengl

recipes-demo:
Various demo applications

recipes-devtools:
MRAA and UPM recipes

recipes-images/angstrom/de10-nano-image.bb:
DE10-Nano image definition

recipes-kernel/de10-nano-linux-firmware:
FPGA related firmware required for fpga configuration and devicetree
overlay support

recipes-kernel/linux:
bbappend to customize configuration of linux kernel as well as patch
in the de10-nano devicetree

recipes-misc:
various initialization and systemd scripts

recipes-qt/qt5:
bbappend to modify qt build options

recipes-support/neon:
bbappend to remove unwanted package

recipes-support/upower:
bbappend to remove unwanted package

recipes-webserver:
webserver configuration and webcontent for board hostedweb portal

recipes-xfce/thunar-volman:
bbappend to remove unwanted package

recipes-xfce/xfce-pointers:
add configuration so that xfce does not use the adxl input as a mouse

recipes-xfce/xfce4-settings:
bbappend to remove unwanted package

Signed-off-by: Westergreen, Dalon <dalon.westergreen@intel.com>
---
 .../files/de10-nano-fpga-leds.service              | 10 +++++++
 .../files/de10-nano-fpga-leds.sh                   | 34 ++++++++++++++++++++++
 2 files changed, 44 insertions(+)
 create mode 100644 recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.service
 create mode 100755 recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.sh

(limited to 'recipes-misc/de10-nano-fpga-leds/files')

diff --git a/recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.service b/recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.service
new file mode 100644
index 0000000..9f4f94e
--- /dev/null
+++ b/recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Start FPGA LEDs
+After=de10-nano-fpga-init.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/de10-nano-fpga-leds.sh
+
+[Install]
+WantedBy=basic.target
diff --git a/recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.sh b/recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.sh
new file mode 100755
index 0000000..073474e
--- /dev/null
+++ b/recipes-misc/de10-nano-fpga-leds/files/de10-nano-fpga-leds.sh
@@ -0,0 +1,34 @@
+#!/bin/sh
+#
+# The MIT License (MIT)                                                        
+# Copyright (c) 2016 Intel Corporation                                         
+#                                                                              
+# Permission is hereby granted, free of charge, to any person obtaining a copy 
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights 
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell    
+# copies of the Software, and to permit persons to whom the Software is        
+# furnished to do so, subject to the following conditions:                     
+#                                                                              
+# The above copyright notice and this permission notice shall be included in   
+# all copies or substantial portions of the Software.                          
+#                                                                              
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR   
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,     
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE  
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER       
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN    
+# THE SOFTWARE.                                                                
+#  
+sleep 5
+CLASS_LEDS_DIR=/sys/class/leds
+
+for i in $(ls -d $CLASS_LEDS_DIR/fpga_led*); do
+	echo oneshot > $i/trigger
+done
+
+for i in $(ls -d $CLASS_LEDS_DIR/fpga_led*); do
+	echo 1 > $i/shot
+	sleep 1
+done
-- 
cgit v1.1